WhatsApp a anunțat că nu va mai rula pe dispozitive vechi. Sunt afectate diverse versiuni de Android, dar și de iPhone ori Windows Phone. Data de la care va intra în vigoare acest lucru este 1 februarie 2020. Compania, deținută de Facebook, spune că schimbarea este necesară pentru a putea asigura în continuare, optim, securitatea utilizatorilor săi.

Astfel, WhatsApp nu va mai funcționa pe iPhone care rulează sistemele de operare iOS 8 sau cele anterioare acestuia. iOS 8 a fost  introdus de Apple în 2014. Practic sunt afectați cei care dețin aparate mai vechi de iPhone6. În ceea ce privește posesorii de telefoane cu sistem Android, vor avea probleme cei cu versiuni mai vechi decât Gingerbread – 2.3.3., care a fost lansată în 2010.

Orice persoană cu telefon cu sisteme mai vechi de operare va încerca să își creeze un cont nou sau să verifice ori să folosească un cont existent folosind variante mai vechi de iOS 8 sau Gingerbred, va fi blocată de aplicație.